MT 3.16 - upgrade using tar file not piecemeal using zip

|

Last Words: Odd bug? I uploaded the entire tar package to the destination directory with filezilla, untar'd, then copied the contents of MT-3.16-upgrade-en_US/ to the destination directory (cp -rf . ..) which seems to have fixed the problem. Normally I take the easier route and download the zip pkg, unzip, then upload all files except for images/ directory in ASCII and images/ directory in binary as I have done several times following the "upgrade directions". So, possibly upgrade using the first method and not the second.

This might be a bug unique to a few including myself as others have successfully upgraded. Is it the subdomains which are causing a problem?
Yes, I altered my post because it seems that I was a bit harsh to the six apart crew who can now resume their bathroom breaks. see below
Yesterday I installed MT 3.16 using my usual zip and upload via ASCII or Binary appropriate method only to come upon an odd error while trying to post today. It has a repeating login bug and isn't keeping track of login state or some such thing. There is more information on the support board

If you've already done the upgrade and are experiencing the same problem, there are two choices you can make.
1. Downgrade - re-upload the old MT-3.15 overwriting MT-3.16 folders.
2. Unpack upgrade on your server instead of desktop- Upload the tar file to your server, unpack (tar -zxvf MT-3.16.tar.gz should do it for linux users with shell access), and copy the files from the newly created MT-3.16-upgrade-en_US/ into destination directory (cp -rf . .. - copy all files from this directory to the directory above this one)

Now, I am for progress but I'm not usually willing to subject myself to excessive beta testing either (unless the tool is a good one and relatively stable) but for this kind of error to occur in a commercial product is notsogood. In part I can only cringe in horror and sympathy as this is a software company's equivalent to multiple swear words and brewing endless pots of coffee while not having the time to go to the bathroom. I can only hope that this hasn't happened to many upgraders as login happens to be core and not "frills". Not an easily ignorable bug. In my own defense, I thought 3.16 sounded like a good upgrade that fixed a decent amount of bugs and offered some new features I'd like. it is a larger bug fix

Wonder if people who use remote blogging apps like ecto are similarly affected since they use a different interface and posting method (I think they use a different API).

I'll poke about a bit and see if I can't figure out what is going on. And my problems seem to be solved though I'm not sure what went wrong in the first place. Used the same method I usually use